Apache, PHP Upgrades

PHP 4 is approaching EOL, and Birdhouse Hosting, like many hosts, has been in “pause” mode on the prospect of a PHP 5 upgrade for a while, cautious of the possibility of breaking customer scripts. We’ve also been running on Apache 1.3.x since forever. But after much research, finally decided it was safe to just go for it. Spent the afternoon and early evening compiling Apache 2.2.8 and PHP 5.2.5, all required modules, tweaking handlers, and taking care of a few post-upgrade burps. Everything seems to be running smoothly, with not a single customer complaint (let us know if you find anything not working!)

Stay tuned for a revamped hosting site and a new pricing structure in the coming months.

Leave a Reply

Your email address will not be published.